500 Errors Loading Seesaw app
Incident Report for Seesaw
Resolved
This incident has been resolved.
Posted Jun 20, 2024 - 14:55 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 20, 2024 - 14:40 PDT
Identified
Between 1:05pm - 2:31pm pacific, Seesaw experienced an elevated level of API errors. We've identified that up to 2,600 schools and districts who are in the 'Seesaw Instruction & Insights' tier received a 500 error when accessing our site. We are working to restore their access.
Posted Jun 20, 2024 - 14:25 PDT
Investigating
We are currently investigating an issue where a small percentage of users are experiencing 500 errors across the site.
Posted Jun 20, 2024 - 13:46 PDT
This incident affected: Seesaw.