Seesaw: Empty Inbox / "Disappearing" Messages
Incident Report for Seesaw
Resolved
Due to an infrastructure outage, some users briefly saw an empty messages inbox in Seesaw. Some Seesaw users experienced this issue for brief periods of time between May 8 and May 14th, and we have since fixed the underlying issue. If you tried to send messages during this time, we recommend re-sending your message — you should be able to view and send messages as normal.

We will continue to monitor and will also reach out to users who were impacted by this issue with further information.
Posted May 14, 2024 - 17:18 PDT
Identified
We are aware of reports of missing messages from the Seesaw application that impacted some users on May 8, 13, 14 for brief periods of time, approximately over a total period of 6hrs spread over those 3 days.

We have identified the root cause and are working on impact metrics to recover any messages that are missing from / sent during the impacted time periods.
Posted May 08, 2024 - 13:28 PDT
This incident affected: Seesaw.