[Investigating] We are currently investigating issues with Google Sign in on the Seesaw Website.

Incident Report for Seesaw

Resolved

We have resolved the issue impacting Google Sign In to the Seesaw website.
Posted Jul 26, 2023 - 11:00 PDT

Investigating

We are currently investigating this issue.
Posted Jul 26, 2023 - 09:59 PDT
This incident affected: Seesaw.