ClassLink API Sync Issue
Incident Report for Seesaw
Resolved
ClassLink notified us that our original supported API is working again. We tested and confirmed, and have switched back, so syncs from now on will run using the original supported API as before.

Please reach out to ClassLink and Seesaw support if you experience any issues with your sync as a result of the API switches.
Posted Aug 16, 2021 - 08:22 PDT
Monitoring
We have patched a change to use a newer version of the ClassLink API as a temporary workaround while we wait for the ClassLink team to fix the API we are currently using. Roster Sync dashboards for ClassLink districts should now load and be able to run syncs (note that you may need to hard refresh). We have also unpaused district syncs and run all nightly syncs from 8/15 using the new ClassLink API.

As a reminder — Because this is a new API there may be some unpredictable issues that come up, which customers should report to ClassLink if observed. If customers are able to wait, we recommend waiting to run a manual sync until after ClassLink has fixed our supported API and we are able to revert back.
Posted Aug 16, 2021 - 00:44 PDT
Identified
ClassLink has identified that the issue is with the version of the ClassLink API we are currently using. We are patching a change to use a newer version of the ClassLink API as a temporary workaround while we wait for the ClassLink team to fix the API we are currently using. We will also unpause and rerun all nightly syncs from 8/15 using the new ClassLink API.

Because this is a new API there may be some unpredictable issues that come up, which customers should report to ClassLink if observed. If customers are able to wait, we recommend waiting to run a manual sync until after ClassLink has fixed our supported API and we are able to revert back.
Posted Aug 16, 2021 - 00:31 PDT
Update
We have preemptively paused all ClassLink district syncs while this issue is being investigated.
Posted Aug 15, 2021 - 20:15 PDT
Investigating
At 12:17pm PT we discovered a ClassLink-side API connection issue. This prevents the loading of our Roster Sync dashboard and prevents syncing for ClassLink districts. We are in active communication with the ClassLink Team who is investigating the issue.
Posted Aug 15, 2021 - 20:03 PDT
This incident affected: Seesaw.