Email Sending Delays

Incident Report for Seesaw

Resolved

The issue with our downstream email service provider is resolved and all delayed emails have been sent.
Posted Sep 29, 2022 - 17:30 PDT

Update

The issue with our downstream email service provider is resolved and we are currently sending email notifications. We will update again when all delayed emails have been sent.
Posted Sep 29, 2022 - 16:45 PDT

Identified

We have identified an issue where email notifications are delayed due to an issue with our downstream email service provider. All email notifications will be sent, but users may experience a delay in email delivery. We update again when the delay is resolved.
Posted Sep 29, 2022 - 15:02 PDT
This incident affected: Seesaw.