Push Notification Causing iOS Crash on 10.89

Incident Report for Seesaw

Resolved

Following continuous monitoring, the team confirms that this issue is resolved.
Posted Aug 15, 2025 - 16:23 PDT

Monitoring

The fix has been released in the new version 10.89.1 of the app.
We have been able to confirm that opening the app from a push notification no longer crashes the app.
The team is monitoring the fix to ensure it continues to work as intended.
Posted Aug 15, 2025 - 14:19 PDT

Identified

A fix has been identified, and a new version of the app has been submitted to the iOS App Store for review.
Posted Aug 14, 2025 - 18:56 PDT

Investigating

We’ve identified an increase in crashes when opening the app from a push notification on iOS version 10.89. Entering the app from the Home Screen works normally. Our team is actively investigating and working on a fix.
Posted Aug 14, 2025 - 07:48 PDT
This incident affected: Seesaw.