Slowness Loading Seesaw
Incident Report for Seesaw
Resolved
This incident has been resolved.
Posted Nov 13, 2019 - 13:46 PST
Update
Users should no longer be experiencing slowness or 500 errors.
Posted Nov 13, 2019 - 13:44 PST
Investigating
We are currently investigating an issue where Seesaw is slow to load (journal tab, activities tab) or users could experience an intermittent 500 error.
Posted Nov 13, 2019 - 13:38 PST
This incident affected: Seesaw.