Slowness Loading Seesaw and Periodic 500 Errors

Incident Report for Seesaw

Resolved

This incident has been resolved.
Posted Aug 06, 2020 - 16:56 PDT

Investigating

We're currently investigating slowness loading the site and periodic 500 errors.
Posted Aug 06, 2020 - 16:42 PDT
This incident affected: Seesaw.