AWS Outage Impacting Third-Party Authentication

Incident Report for Seesaw

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 18:23 PDT

Monitoring

Some third-party authentication services, including Clever and ClassLink, are currently experiencing disruptions due to an AWS outage. This may impact your ability to log in using these services. Seesaw is actively monitoring the situation. Please note, this is not a bug in Seesaw. We will provide updates as more information becomes available.
Posted Oct 20, 2025 - 10:26 PDT