Periodic Errors Across the Site (0.0002% of Requests)
Incident Report for Seesaw
Resolved
This incident has been resolved.
Posted Aug 18, 2020 - 19:03 PDT
Investigating
We are currently investigating a low number of errors (0.0002% of requests) across the site.
Posted Aug 18, 2020 - 18:20 PDT
This incident affected: Seesaw.