2%-5% of Users Experiencing Issues Loading Posts and Uploading
Incident Report for Seesaw
Resolved
This issue has been resolved.
Posted Mar 30, 2020 - 18:11 PDT
Investigating
2%-5% of Seesaw users in specific locations are currently experiencing 4XX and 5XX errors starting at 3:15 pm. We are currently investigating.
Posted Mar 30, 2020 - 17:01 PDT
This incident affected: Seesaw.