Scheduled Messages Delayed

Incident Report for Seesaw

Resolved

This incident is now resolved. Customers will receive all messages that were scheduled during our downtime.
Posted Jan 28, 2026 - 11:53 PST

Identified

We are currently experiencing delays in the delivery of scheduled messages. Our team has identified the cause of this issue and working to resolve it. Scheduled items may arrive later than expected.
Posted Jan 28, 2026 - 10:16 PST
This incident affected: Seesaw.