Potential delay in email notifications

Incident Report for Seesaw

Resolved

This issue has been resolved and email notifications are being delivered normally.
Posted Jun 07, 2022 - 10:36 PDT

Identified

We have identified an issue where some email notifications are delayed due to an issue with our downstream email service provider. All email notifications will be sent, but users may experience a delay in email delivery.
Posted Jun 07, 2022 - 09:22 PDT
This incident affected: Seesaw.