[Investigating] We are currently investigating issues with Google Sign in on the Seesaw Website.
Incident Report for Seesaw
Resolved
This incident is resolved.
Posted Jun 29, 2023 - 11:45 PDT
Investigating
We are currently investigating this issue.

Users can continue to sign into Seesaw via Google SSO on the mobile applications with no issues.
Posted Jun 29, 2023 - 10:45 PDT
This incident affected: Seesaw.