Potential delay in email notifications
Incident Report for Seesaw
Resolved
This issue has been resolved and email notifications are being delivered normally.
Posted Jun 09, 2022 - 07:24 PDT
Update
We are seeing signs of recovery from our downstream email provider and are working through the delayed emails. We expect all delayed email notifications to be correctly sent in the next hour or earlier.
Posted Jun 09, 2022 - 06:55 PDT
Identified
We have identified an issue where some email notifications are delayed due to an issue with our downstream email service provider. All email notifications will be sent, but users may experience a delay in email delivery.

You can view the status of our email provider here: https://status.mailgun.com/
Posted Jun 09, 2022 - 05:37 PDT
This incident affected: Seesaw.