Slowness and Occasional 500 Errors
Incident Report for Seesaw
Resolved
This incident has been resolved.
Posted Jun 26, 2020 - 15:16 PDT
Update
This issue has been resolved.
Posted Jun 26, 2020 - 15:16 PDT
Investigating
We’re seeing increased slowness loading the site and occasional 500 errors. We are currently investigating.
Posted Jun 26, 2020 - 11:48 PDT
This incident affected: Seesaw.